Sponsor Message:
Aviation Photography Forum
My Starred Topics | Profile | New Topic | Forum Index | Help | Search 
Sigma 170 500 Mm APO Lens  
User currently offlineRyan h From Australia, joined Aug 2001, 1575 posts, RR: 1
Posted (10 years 9 months 1 week 4 hours ago) and read 7062 times:

I have just purchased one of these lenses and was wondering if anybody could give me any advice.


South Australian Spotter
20 replies: All unread, jump to last
 
User currently offlineDazultra From United Kingdom, joined Nov 2003, 689 posts, RR: 41
Reply 1, posted (10 years 9 months 1 week 4 hours ago) and read 7056 times:

I know Rez Manzoori uses this (BIGMA!  Big thumbs up) lens Im sure he'l be happy to give you some tips


Daz.


User currently offlineAndyhunt From Singapore, joined Jan 2001, 1306 posts, RR: 52
Reply 2, posted (10 years 9 months 6 days 22 hours ago) and read 7007 times:
AIRLINERS.NET CREW
PHOTO SCREENER

I use one, what help do you need?

(Gary Watt also uses one, albeit badly!) Big grin

Andrew



Full frame always beats post processing
User currently offlineRyan h From Australia, joined Aug 2001, 1575 posts, RR: 1
Reply 3, posted (10 years 9 months 6 days 18 hours ago) and read 6990 times:

I am having lots of trouble with mine. The camera will let me take one shot and then error 99 will come up on the status screen.


South Australian Spotter
User currently offlineAndyhunt From Singapore, joined Jan 2001, 1306 posts, RR: 52
Reply 4, posted (10 years 9 months 6 days 17 hours ago) and read 6980 times:
AIRLINERS.NET CREW
PHOTO SCREENER

Do you get the same from your other lneses, could be the camera or the lens?

Andrew



Full frame always beats post processing
User currently offlineRyan h From Australia, joined Aug 2001, 1575 posts, RR: 1
Reply 5, posted (10 years 9 months 6 days 17 hours ago) and read 6973 times:

The kit lens that came with the 300D and a 75-300 mm lens I bought at the time I bought the camera work perfectly.


South Australian Spotter
User currently offlineAndyhunt From Singapore, joined Jan 2001, 1306 posts, RR: 52
Reply 6, posted (10 years 9 months 6 days 17 hours ago) and read 6963 times:
AIRLINERS.NET CREW
PHOTO SCREENER

Sounds strange to me, I just got the D70 and have tried a few test shots, works well. Have you checked the compability lens chart in the manual?

Other Canon shooters........Gary?

Andrew



Full frame always beats post processing
User currently offlineManzoori From UK - England, joined Sep 2002, 1516 posts, RR: 33
Reply 7, posted (10 years 9 months 6 days 16 hours ago) and read 6955 times:

Wahay! A Name check! Thanks Daz!  Big thumbs up

Ryan,

Sorry to hear about the problems mate. Just in case you don't know, Error 99 indicates a hardware incompatibility, though quite why it would work once and then not the next is beyond me.

I've not experienced this problem myself but have just googled for the problem and you're not alone! This site has some blogs of people with similar problems... maybe one of them has a fix?

It seems to boil down to Sigma not paying royalty fees to make EF lenses and having to reverse engineer them. Sometimes when a new body comes out they are caught short on the specs.... apparently!

Out of interest is the BIGMA new or S/H? One of the bloggers mentions having Sigma change the electronics in his BIGMA to get it to work.

Hope this helps and I hope you get the problem fixed soon!

Cheers!

Rez
 Big thumbs up



Flightlineimages DOT Com Photographer & Web Editor. RR Turbines Specialist
User currently offlineRyan h From Australia, joined Aug 2001, 1575 posts, RR: 1
Reply 8, posted (10 years 9 months 6 days 16 hours ago) and read 6947 times:

Mine is secondhand. I will check the site you mentioned to see what it says.


South Australian Spotter
User currently offlineDazed767 From United States of America, joined May 1999, 5498 posts, RR: 51
Reply 9, posted (10 years 9 months 6 days 15 hours ago) and read 6939 times:

I believe that is the same error I had with my Sigma 17-35mm lens on my D30. It only happened once. I just turned it off, took out the batteries for a few mins. After that it was fine, hasn't happened again (happened about 7 months ago).

Justin


User currently offlineAndreasE From Norway, joined Mar 2004, 9 posts, RR: 0
Reply 10, posted (10 years 9 months 6 days 15 hours ago) and read 6929 times:

Hi

I'm using a Canon 10D with a brand new Sigma 170-500 mm APO, no problem whatsoever !

Best
Andreas


User currently offlineCraigy From United Kingdom, joined Jun 2001, 1118 posts, RR: 0
Reply 11, posted (10 years 9 months 6 days 12 hours ago) and read 6899 times:

My 170-500 is nearly two years old now and works fine on the EOS-30 and 10D.

The very early 170-500s needed to be re-chipped to work on the 10D I believe, but mine is new enough not to have needed it.

Craig.


User currently offlineGranite From UK - Scotland, joined May 1999, 5577 posts, RR: 63
Reply 12, posted (10 years 9 months 6 days 4 hours ago) and read 6858 times:
Support Airliners.net - become a First Class Member!

Hi all

Sorry, never came across the error 99 before.

Been using the lens with the D30 for a few years now and with no problems or error messages.

Andrew.....you know I take a good image.......slagging me off makes you look like a tart!

Cheers

Gary


User currently offlineRyan h From Australia, joined Aug 2001, 1575 posts, RR: 1
Reply 13, posted (10 years 9 months 6 days 3 hours ago) and read 6851 times:

Thanks for all the replies.
It looks like that I will have to get it re chipped or if that can't be done get my money back from the shop and buy a new one.



South Australian Spotter
User currently offlineWoody001 From United Kingdom, joined Feb 2004, 529 posts, RR: 22
Reply 14, posted (10 years 9 months 6 days 2 hours ago) and read 6833 times:

I had the same code appear on my 10D when using an older Sigma lens I'd bought several years ago. It would allow me to take one shot then lock up and display the error code. It seems to happen when the camera alters the aperture setting of the lens, you can check this by setting the camera in aperture priority mode and then picking the smallest aperture (high f number) and then press the depth of field preview button - the camera will lock up and indicate error 99.

Here in the UK Sigma are pretty good and re-chipped my lens in 3 days. It will cost you more if you didn't own the lens from new so my advice would be to take the lens back to the shop and wait until you find a newer version, or get the shop to cough up for the re-chipping fee.

I use the 170-500mm, it's a good lens for the money, just don't expect Canon L quality shots.

Best of luck,
Ian.




If I could just get the afterburner working...
User currently offlineTwr75 From Australia, joined Mar 2001, 111 posts, RR: 1
Reply 15, posted (10 years 9 months 6 days 2 hours ago) and read 6825 times:

I have only had an error99 with the 10D/170-500 combo once, and that was taking multiple shots one after another (airshow) in fairly hot conditions (31 C+ with the camera and lens in direct sunlight). In lulls in the display program I put the camera and lens in the esky to cool things down and it worked OK again until it got hot again. A week later at another airshow in much cooler conditions everything worked OK.


Like a seagull on the MCG of life...
User currently offlineDehowie From Australia, joined Feb 2004, 1067 posts, RR: 33
Reply 16, posted (10 years 9 months 5 days 23 hours ago) and read 6817 times:

G'day Ryan
get onto the Sigma HQ in Melbourne and they will rechip it for free.
If you have a distributor in your state they will post it to Melb for you.
Great service from them.
Just out of interest is the performance of the 170-500 or 50-500 better at the 500mm position when compared to one another?
I got some good rsults at 500mm with the 50-500 but i am wondering if the performance of the 170-500 is better at long range.
Thanks
Darren



2EOS1DX,EF14.2.8LII,17TS,85/1.2,16-35L,24-70LII,24L,70-200F2.8LII,100-400,300/400/500/800L
User currently offlineRG828 From Brazil, joined Jan 2004, 582 posts, RR: 1
Reply 17, posted (10 years 9 months 3 days 12 hours ago) and read 6754 times:
AIRLINERS.NET CREW
PHOTO SCREENER

Just to clear a doubt I have:
Is the "Bigma" the 170-500 or 50-500 EX?



I dont know the key to success, but the key to failure is trying to please everyone
User currently offlineManzoori From UK - England, joined Sep 2002, 1516 posts, RR: 33
Reply 18, posted (10 years 9 months 3 days 9 hours ago) and read 6745 times:

Depends who you talk to really... I suppose you could say the 50-500 with it's 10x zoom range is the real Bigma, but to me... my beautiful 170-500 is my BIGMA!

Cheers!

Rez
 Big thumbs up



Flightlineimages DOT Com Photographer & Web Editor. RR Turbines Specialist
User currently offlineUngoMongo From Denmark, joined Aug 2001, 146 posts, RR: 1
Reply 19, posted (10 years 9 months 2 days 21 hours ago) and read 6694 times:

Hi

I have read, that here in Denmark, they re-chip is for free.  Smile

Cheers



Becoming a dad is the greatest.
User currently offlineRyan h From Australia, joined Aug 2001, 1575 posts, RR: 1
Reply 20, posted (10 years 9 months 2 days 14 hours ago) and read 6694 times:

At the moment it is being rechipped for free.
Can anyone offer any tips the get the best from it?



South Australian Spotter
Top Of Page
Forum Index

This topic is archived and can not be replied to any more.

Printer friendly format

Similar topics:More similar topics...
Sigma 170-500... Opinions? posted Tue Jan 10 2006 20:41:57 by Andz
D30 & Sigma 170-500 Focusing Issue posted Wed Apr 14 2004 07:28:27 by Manzoori
Canon 300D + Sigma 50-500 APO ...experience!? posted Mon Dec 27 2004 14:27:50 by Wernair
Sigma APO 50-500 Vs APO 100-400 SO posted Wed Aug 11 2004 23:51:05 by Volare
Where To Buy Sigma 170-500mm Lens In Hong Kong posted Tue Mar 11 2003 16:38:21 by Sepang
New Sigma 170-500mm Lens - Problem? posted Wed May 22 2002 21:43:13 by Kaitak
Sigma 50-500 Or Canon 100-400L Is posted Mon Jul 10 2006 07:52:38 by Franzloew
18+ Mm Zoom Lens Recommendation posted Mon Mar 6 2006 16:48:42 by Ariis
Sigma 170-500mm posted Thu Sep 22 2005 09:46:17 by EGFF
Sigma 50-500 EX - My Review posted Mon May 16 2005 04:17:53 by Mikec