Sponsor Message:
Aviation Photography Forum
My Starred Topics | Profile | New Topic | Forum Index | Help | Search 
Help! Trying To Diaganose Pentax Problem  
User currently offlineL-188 From United States of America, joined Jul 1999, 29813 posts, RR: 58
Posted (12 years 5 months 1 day ago) and read 2381 times:

My Pentax PZ-70 just took a dump on me today.

I was at the airshow yesterday, and was running a roll of Kodacrome through it when it got to shot 17, it sensed the roll was finished and then started to rewind. It only rewound down to about shot 10 and then stopped.

I went ahead and in a darkroom bag very carefully removed that roll of film. I bought a new battery, thinking that was the problem, and tried it again. This time with a new roll of film I think I got about three or four shots in when the shutter stopped opening. I could hear the mirror comming up out of the way of the shutter and returning at the end of the shot. But the shutter was not opening, No matter what speed was set in the camera, either manually or automatically by the camera. And I could tell that the camera was not advancing the film also.


I don't have any sort of error indicators on the camera displays and I noted no visible damage to the shutter curtains when I got the second role of film out, which rewound normally after hitting the partial roll rewind button on the camera.

I am going to wait until I get the film back from the developer to see if there are any clues as to what is going on in the shots themselves that I may have gotten.

Any of you all out there have any ideas what it up?

Thanks for any help.


OBAMA-WORST PRESIDENT EVER....Even SKOORB would be better.
2 replies: All unread, jump to last
 
User currently offlineBoeingholiday From Austria, joined Apr 2002, 456 posts, RR: 4
Reply 1, posted (12 years 5 months 15 hours ago) and read 2360 times:

Hi, I'm also a Pentax user and maybe there's a bug in the system of the camera. Maybe the sensor doesn't work right who shows the camera if the film is out of free photos or not. This can be caused by dirt or other stuff which should not be in a Pentax. But please don't clean it yourself! This part of a camera is one of the most difficult one!

User currently offlineL-188 From United States of America, joined Jul 1999, 29813 posts, RR: 58
Reply 2, posted (12 years 4 months 4 weeks 1 day 6 hours ago) and read 2351 times:

Well talked to my Pentax guy today.

He thought what was wrong was that the link between the shutter solinoid and the shutter broke.

Problem is that it takes about three hours to get in there, Pentax only sells the whole shutter thing as an assembly.

He didn't think it was economicly repairable  Crying

Damm, I liked that camera.



OBAMA-WORST PRESIDENT EVER....Even SKOORB would be better.
Top Of Page
Forum Index

This topic is archived and can not be replied to any more.

Printer friendly format

Similar topics:More similar topics...
Help! Trying To Enter The Hobby. posted Sat Jun 22 2002 06:46:46 by Westjet_737
Trying To Avoid Bad_Info. Please Help. posted Sat Nov 5 2005 18:22:56 by UnattendedBag
Help Me To Spot The Dust posted Sat Nov 18 2006 19:28:38 by NicolasRubio
Please Help Me To Level This Pic posted Fri Nov 3 2006 13:01:46 by Pitchul
Some Help Needed To Improve The Quality posted Tue Sep 26 2006 16:46:46 by Avro85
Trying To Find A Good, Cheap Camera... posted Wed Aug 9 2006 06:03:36 by Flinhion757
Trying To Get Photo #2 Up... posted Fri Mar 24 2006 20:20:44 by ZSOFN
Trying To Locate A Photo... posted Mon Mar 6 2006 00:42:05 by Sleekjet
Help Needed To Improve My Rejected Pictures posted Mon Nov 21 2005 21:25:20 by Avro85
Trying To Avoid A Rejection On This One posted Thu Aug 4 2005 21:03:09 by Senorcarnival