Sponsor Message:
Aviation Photography Forum
My Starred Topics | Profile | New Topic | Forum Index | Help | Search 
C-700 Problem On The C730?  
User currently offlineSingapore 777 From Australia, joined May 1999, 1014 posts, RR: 3
Posted (11 years 7 months 3 weeks 2 days 15 hours ago) and read 1371 times:

I heard from my friend that his C700 has some problem starting up. Sometimes when he tries to start up his camera, it has like some "ignition problem" and it makes an unnerving noise. I would like to ask if any users of the C730 have experienced this problem and how widespread is this problem amongst the Olympus C-series camera line?

Any help would be greatly appreciated.

2 replies: All unread, jump to last
 
User currently offlineKLAX From , joined Dec 1969, posts, RR:
Reply 1, posted (11 years 7 months 3 weeks 2 days 9 hours ago) and read 1337 times:

Dont get me all scared! I just ordered a C-730UZ Big grin

I havn't heard anything about this problem anyway.

-Clovis


User currently offlineJeffM From United States of America, joined May 2005, 3266 posts, RR: 52
Reply 2, posted (11 years 7 months 3 weeks 1 day 8 hours ago) and read 1319 times:

Never heard it on mine either, and I took a ton of shots with it. And I even dropped it a few feet in the car once as well. None the worse for the wear...

Jeff


Top Of Page
Forum Index

This topic is archived and can not be replied to any more.

Printer friendly format

Similar topics:More similar topics...
SXM On The Run posted Thu May 24 2007 02:14:38 by Sluger020889
Black Spot On The Lens? posted Mon Jan 29 2007 00:39:38 by LIPH
More On The Nikon 70-300 VR posted Wed Jan 3 2007 04:52:04 by D L X
Will This Photo Get On The Database? posted Sun Dec 31 2006 23:28:51 by Jamesbaldwyn
Any News On The Nikon 70-300 VR... posted Sun Dec 3 2006 18:32:06 by D L X
Taking Night Shots On The Move - Help For A Novice posted Fri Oct 27 2006 17:38:39 by RobK
Does Photo Sales Function $$ On The Site Suck? posted Sun Oct 15 2006 16:23:27 by Eksath
20D LCD On The Frizz... posted Fri Sep 15 2006 17:52:47 by Fiveholer
Dust On The Sensor That Won't Come Off posted Wed May 31 2006 15:09:53 by BA
Setting F-stops On The Nikon D50 posted Thu May 18 2006 03:28:26 by Cadet57