Sponsor Message:
Non Aviation Forum
My Starred Topics | Profile | New Topic | Forum Index | Help | Search 
Anyone Here Have Experience With Asterisk?  
User currently offlineLincoln From United States of America, joined Nov 2004, 3887 posts, RR: 8
Posted (6 years 7 months 2 weeks 1 day 3 hours ago) and read 1514 times:

If you do... I have a problem that's driving me crazy. (If you don't I'm primarially posting this to clear my head and talk myself out of jumping off the roof  Smile )

I'm using a Grandstream HT-488 to bridge a POTS line into my VOIP world [primarially Cisco 79xx IP phones].

I had everything more or less working the way I wanted it to -- incoming calls went to the auto attendant I had set up in Asterisk, I could make an outgoing call from the phones by dialing 9 and the phone number. The one huge problem I had was calls to or from the outside world would randomly drop very early in the conversation.

Over the Christmas break, I was hell bent on fixing it so that that didn't happen. I found in the firmware release notes on Grandstream's website that this issue had been fixed in a firmware release (I also found out that the HT-488 wasn't automatically downloading new firmware as I understood it was). So I upgraded to the current version of firmware.

From then until roughly today incoming calls haven't dropped, though occassionally it would miss an incoming call completely, and my ability to make outgoing calls has been somewhat iffy [about half the time I'd get a "Line Busy" response]

When I came home tonight I was determined to fix both of those problems.

Lots of clicking and trying and clicking and rebooting later (though I want to swear I'm exactly where I started) I'm now in the position where incoming calls are consitently and properly handled, but I am completley unable to place an outgoing call.

Being the relative Asterisk noob that I am... Any suggestions from those who have pitty for my ignorance?

Here's the sip.conf entry I have for the FXO port:
[FXO1]
type=friend
secret=FXO1
context=incoming
qualify=yes
nat=no
host=dynamic
defaultip=192.168.11.4
canreinvite=no
dtmfmode=auto
callerid="Outside Caller" <9>

Here's the extensions.conf entry that had been working:
; Dial 9 for an outside line
ignorepat => 9
exten => _9.,1,Dial(SIP/FXO1,60,D(w${EXTEN:1}))
exten => _9.,2,Hangup()

And here's what I added just in case something was funky with the Dial():
exten => 7000,1,Dial(SIP/FXO1)
exten => 7000,2,Hangup()


CO Is My Airline of Choice || Baggage Claim is an airline's last chance to disappoint a customer || Next flts in profile
Top Of Page
Forum Index

This topic is archived and can not be replied to any more.

Printer friendly format

Similar topics:More similar topics...
Does Anyone Here Have A Motorola V3? posted Wed Dec 19 2007 06:35:03 by Express1
Anybody Have Experience With Land Rovers? posted Sun Jul 22 2007 21:08:52 by MD11Engineer
Anyone Here Have Gmail? posted Wed Jun 16 2004 21:52:40 by JAL777
Does Anyone Here Have Any Use For Rap Music? posted Mon Aug 6 2001 08:13:28 by Lax
Is Anyone Here Familiar With MPG-CAPS? posted Tue Jul 31 2007 05:46:46 by TLG
Euros- Here'syour Chance To Have A Beer With LHMar posted Fri Jun 3 2005 14:44:51 by LHMARK
Anyone In Here Have There G.E.D? posted Sat Mar 12 2005 04:30:10 by Funflyer
Anyone Here Want To Help Me With My Math? posted Mon Sep 13 2004 17:05:40 by KLM672
Anyone Have Experience Of African Baboon Spiders? posted Wed Jun 4 2003 00:24:03 by Ryanb741
Anyone Else Here Have Asperger's? posted Thu Jan 31 2002 01:59:59 by Lowfareair