Sponsor Message:
Non Aviation Forum
My Starred Topics | Profile | New Topic | Forum Index | Help | Search 
Problems With GeForce 3 Ti 500  
User currently offlineN777UA From United States of America, joined Mar 2010, 0 posts, RR: 0
Posted (11 years 5 months 4 weeks 7 hours ago) and read 703 times:

Hey, anyone out there have the nVidia GeForce 3 Ti 500 video card, and have had problems with it? I got one for Christmas last year, and over the summer, it malfuctioned, so I had it replaced, and now the new one is going beserk. Garbled display and everything. Thankfully I still have my old card, which is working fine (TNT2Pro). I was going to get a new computer in a year or so, but I may move those plans forward. My computer is an 866 mhz Pentium 3.

I'd appreciate any replies.

Top Of Page
Forum Index

This topic is archived and can not be replied to any more.

Printer friendly format

Similar topics:More similar topics...
Major Problems With ULead Video Studio 10 posted Mon Apr 2 2007 04:34:14 by DeltaAVL
Problems With FL350 Plugin On FireFox posted Sun Feb 18 2007 23:29:07 by ConcordeBoy
Problems With AOL And IE posted Wed Feb 7 2007 02:12:01 by Alfa75
Site Access Problems With Safari posted Thu Sep 14 2006 04:07:39 by LHMARK
Why Do We All Have Problems With Woman? posted Fri May 19 2006 12:04:36 by Joffie
Ever Had Problems With Sat Nav? posted Fri May 12 2006 21:58:07 by 9VSPO
Problems With My G String posted Sat Jan 7 2006 20:18:20 by LHMARK
Problems With New X-box 360 posted Fri Nov 25 2005 04:30:55 by Greasespot
Problems With Installing Japanese ATC Game posted Tue Nov 15 2005 09:32:18 by Hkniceguy
Problems With My Laptop Clock? posted Fri Sep 23 2005 17:51:10 by Venezuela747