patroni
Posts: 1372
Joined: Sat Aug 14, 1999 7:49 am

Technical Problem With Canon 300/4 L....

Wed Apr 06, 2005 7:10 am

Hello,

I need some technical advice:

Yesterday morning while shooting at the airport, the integrated (pull/twist) hood of my 300/4 lens was a bit stuck and could not easily be turned. As there was an interesting aircraft approaching, I did what one should never do - and pulled a bit harder. Well, the hood finally moved into its position, but I noticed that there is now a rubber/plastic ring squeezed between the hood and the lens barrel so that I can't stow the hood any more. See the link for a photo:

http://www.contrails.de/photo/temp/problem.jpg

I brought the lens to a dealer in town, but he looked at it for about 0.3 seconds and said that he would have to send it to Canon, which would take about 4 weeks. As there is nothing wrong with the lens itself, I find it hard to believe that only Canon can fix this (BTW it was the same dealer who also told me to never ever clean the sensor on your own...send it to Canon instead, wait 4 weeks....). The bad thing is that there are no good photo shops in my city, but maybe someone here has an idea what I could do to get the 300/4 back in service again without waiting a month? The lens is still under warranty and delivers superb pics (imho)

Cheers,
Tom
 
fergulmcc
Posts: 1877
Joined: Thu Oct 14, 2004 8:36 pm

RE: Technical Problem With Canon 300/4 L....

Thu Apr 07, 2005 12:21 am

Tom

I have this lens as well. Its a brilliant lens and find it great. I don't know what to advise you on but if its still under warranty then maybe put up with the 4 week delay. The hood is fitted and then glued in so I can't see how you can get it off to re-fit it. If you don't want to try and insert it back into position with something then you better send it away.

Fergul Big grin
Zambian Airways, Where the Eagles fly free!!
 
LHRSIMON
Posts: 1315
Joined: Sat Apr 27, 2002 5:59 am

RE: Technical Problem With Canon 300/4 L....

Thu Apr 07, 2005 12:50 am

Yep send it to Canon and try to remember to be a bit more carefull next time Big grin

On another point my duff 300 L F/4.0 has at last returned from Canon today. It took them 3 weeks and they have completely replaced the whole "IS" unit.... Just got to get it home now to see if there's any improvement....

Simon C
Canon 1D Mk III,Canon 20D+17-40 L f4.0,70-200 L IS USM f2.8,400 L USM f5.6,135 mm L f2.0, 50 mm f1.8,1.4 x II extender
 
BREmer
Posts: 498
Joined: Fri May 14, 2004 7:50 pm

RE: Technical Problem With Canon 300/4 L....

Thu Apr 07, 2005 6:36 am

That sucks!! Similar situation to my EF 70-200 L. The filter ring of the UV filter was stuck after I dropped it. The lens is still fine but there was no way I could get the thing off. I bit the sour apple yesterday and sent it in. If you can't do it yourself and the dealer can't help you either that might be your only option.....
No fun, I tell ya  grumpy 

Lukas
 
patroni
Posts: 1372
Joined: Sat Aug 14, 1999 7:49 am

RE: Technical Problem With Canon 300/4 L....

Sat Apr 09, 2005 6:49 am

Thanks folks...
I will check where the nearest Canon service center is and probably send it to them.

@ Lukas: Did you send it to Willich or somewhere else?

Normally I guess a good photo shop should be able to do something, but the problem is that in my area I don't know any such dealer.... Trying to buy an L lens? Ahhh.. nobody has them in stock, has to order them (4 weeks!), of course at the list price. Advice on the lenses? Nope.. I find more on the forums than at a local dealer. And then they complain that people order on the internet...

Sorry for the little rant, I just would LOVE to have a competent photo dealer in my vicinity!!

Cheers,
Tom
 
BREmer
Posts: 498
Joined: Fri May 14, 2004 7:50 pm

RE: Technical Problem With Canon 300/4 L....

Sat Apr 09, 2005 9:00 pm

No, I sent it to the repair center of a photo store in Bremen. If it was the lens itself they would probably send it on to Willich themselves. I agree on the fact that there is no competent photo dealer for L lenses around, not even here in the Bremen area.

Lukas

Who is online

Users browsing this forum: No registered users and 1 guest