emair
Topic Author
Posts: 95
Joined: Thu Sep 14, 2006 11:12 pm

Sigma Lens Issue

Mon Mar 25, 2013 11:41 pm

Hey guys,

I have an issue with my Sigma Sigma 170-500mm F5-6.3 DG APO and I hope you guys can help me out.

Here is the issue I'm having with it. It doesn't matter what setting I set and it still doesn't focus when is out more than 300mm on a far away object however, If I'm close to an object and it's all the way out (500mm) it does focus. For the past years this lens has been working very well. Had this issue since two years now.

I believe the problem is inside the lens, I think the "focusing ring" isn't working properly however, I have never open by myself a lens and try to fix it, I might be completely wrong.

Did anyone had this issue before?

Thanks in advance!

Emair =)
 
oly720man
Posts: 5805
Joined: Fri May 21, 2004 7:13 am

RE: Sigma Lens Issue

Tue Mar 26, 2013 11:08 am

The lens does what the camera tells it to do. It's more likely that with things far away at the higher focal lengths you're not getting the contrast for the AF to work, especially if it does work when things are closer. This may reflect a deterioration somewhere in either the lens or camera and would require one or other to be serviced. It's not something you could do yourself.
wheat and dairy can screw up your brain
 
emair
Topic Author
Posts: 95
Joined: Thu Sep 14, 2006 11:12 pm

RE: Sigma Lens Issue

Tue Mar 26, 2013 11:30 am

You are right saying the lens does what the camera tells it do however, I tried this lens on my other camera, just to make sure the issue was not on the camera, and I had the same problem. This lens used to be fine however, is 7+ years old, that might be a factor, just wondering if someone had the same issue..

Emair =)
 
dazbo5
Posts: 2717
Joined: Tue Mar 29, 2005 8:05 am

RE: Sigma Lens Issue

Tue Mar 26, 2013 11:13 pm

Email,

It sounds like an af motor fault. I had a similar problem with my 50-500 that required a motor change. Send it back to sigma for a look and repair. It it's just the motor, they charged me around £90.

Darren
Equipment: 2x Canon EOS 50D; Sigma 10-20 EX DC HSM, 50-500 EX APO DG, Canon 24-105 f/4 L, Speedlite 430EX
 
emair
Topic Author
Posts: 95
Joined: Thu Sep 14, 2006 11:12 pm

RE: Sigma Lens Issue

Wed Mar 27, 2013 10:10 pm

Thanks for the answers, will see what I can do, probably send it for repair..

Emair

Who is online

Users browsing this forum: No registered users and 1 guest

Popular Searches On Airliners.net

Top Photos of Last:   24 Hours  •  48 Hours  •  7 Days  •  30 Days  •  180 Days  •  365 Days  •  All Time

Military Aircraft Every type from fighters to helicopters from air forces around the globe

Classic Airliners Props and jets from the good old days

Flight Decks Views from inside the cockpit

Aircraft Cabins Passenger cabin shots showing seat arrangements as well as cargo aircraft interior

Cargo Aircraft Pictures of great freighter aircraft

Government Aircraft Aircraft flying government officials

Helicopters Our large helicopter section. Both military and civil versions

Blimps / Airships Everything from the Goodyear blimp to the Zeppelin

Night Photos Beautiful shots taken while the sun is below the horizon

Accidents Accident, incident and crash related photos

Air to Air Photos taken by airborne photographers of airborne aircraft

Special Paint Schemes Aircraft painted in beautiful and original liveries

Airport Overviews Airport overviews from the air or ground

Tails and Winglets Tail and Winglet closeups with beautiful airline logos